יום ראשון, 30 בספטמבר 2012

4 כללים למדידת פשטות של תוכנה

בעולם התוכנה, קיימים מספר ״כללי אצבע״ מוצלחים, המנחים אותנו כיצד ליצור תוכנה טובה יותר. הייתי רוצה להקדיש לכללים אלו קצת יותר תשומת-לב בבלוג.

אחת ההגדרות שאני אוהב היא של בחור בשם J.B. Rainsberger, הגדרה של ״מבנה פשוט של תוכנה״.

אני משתמש במילה מבנה (structure) לתאר את התוצאה בפועל, בניגוד לתכנון (design) שזו התוכנית, או השאיפה, שלא תמיד מוסכמת על כולם או מתממשת בפועל. עצם קיומו של מסמך design לא מבטיח שלאחר שנה של קידוד - כך באמת תראה התוכנה [א].


ע״פ ריינסברגר (עוד), ישנם ארבעה אלמנטים (עם סדר עדיפויות ברור) המובילים לתוכנה פשוטה:
  1. כל הבדיקות עוברות. 
  2. צמצום כפילויות קוד. 
  3. הקוד מתאר כוונה (clarity). 
  4. צמצום  מספר האלמנטים בקוד למינימום האפשרי  אלמנטים שאינם משרתים את מטרות 1-3.

כל הבדיקות עוברות
העיקרון הראשון הוא דיי ברור - התוכנה עומדת בהתנהגות הרצויה. זה הכי חשוב.
אם אתם לא משתמשים בבדיקות יחידה, אזי:
א. אתם יכולים לתרגם כלל זה ל״נכונות פונקציונליות״.
ב. אתם נמצאים בעמדת נחיתות להשגת קוד פשוט: בדיקות יחידה מאלצות את הקוד להיות מודולרי ופשוט יותר, ובלעדיהן המשימה של השגת קוד-פשוט היא קשה כפליים.


צמצום כפילויות קוד + קוד המתאר כוונה
קריאות הקוד נחשבת לעתים לחשובה לא-פחות מביטול כפילויות בקוד. ריינסברגר טוען שהסרה של קוד כפול מובילה בסה״כ לתוצאות טובות יותר מ״שימוש בקוד כפול לצורך בהירות״. ההמלצה הגורפת שלו היא להעדיף ביטול קוד כפול על פני ניסיון לכתוב קוד ברור יותר. אני נוטה להסכים, וגם מכיר בצורך לספק כללים פשוטים שקל לעקוב אחריהם, אך רוצה לציין הסתייגות בנושא זה.

הנה דוגמה של קוד "ללא כפילויות" שהפריע לי והפכתי לכפול:
אני מסכים, זה לא קוד "מושלם", וספריית templating הייתה יכולה להפוך אותו ליפה יותר, אך זו דוגמה אמיתית מהחיים.

הנה הקוד לאחר השינוי:
זה בהחלט קוד פשוט יותר, למרות כמה שורות קוד כפולות.
כיצד אני מסביר / מרשה כפילות קוד שכזו?
א. הכפילות קרובה פיסית - קל להבין אותה ולהיות מודעים אליה (=> הסיכוי לתקן במקום אחד ולפספס את השני - קטן).
ב. לא מדובר ביותר מ3 שורות קוד רצופות כפולות. זו דוגמה פשוטה - ביצעתי שינויים דומים לקוד ארוך ומסובך יותר (ולא רק שרשור html, אלא גם לוגיקה), אך לעולם לא השארתי יותר מ3 שורות רצופות של קוד כפול.


קוד המתאר כוונה
אם מזקקים את הכלל של "כתיבת קוד המתאר כוונה", לרוב עיקר העבודה היא מסביב לשמות: שמות של פונקציות או משתנים, או שמות חדשים הנוספים ע"י פעולות "extract method" או "introduce variable".

ישנן 4 "דרגות" של שם:
  1. שם סתמי
  2. שם נכון
  3. שם מדויק
  4. שם בעל משמעות ("meaningful").
עצלנות ולחץ גורמים לנו להיצמד לתחתית הסקאלה (1,2), בעוד הקפדה ומקצועיות דוחפים אותנו לראש הסקאלה (3,4).

מאוד נהניתי, כשקראתי את ריינסברגר, כשהוא מתאר בדיוק רב הרגל שגם אני רכשתי: כאשר אני רואה קוד כפול אני מבצע extract method לשורות הכפולות, גם מבלי להבין לעומק מה המשמעות שלהן. פעולה טכנית גרידא.
אני נותן לפונקציה שנוצרה את השם "foo". מבלי לחשוב. תוך כדי עבודה אני מבין מה הפונקציה עושה ומשנה את שמה. לאחר 10 דקות עבודה ייתכן והשם שונה כבר שלוש או ארבע פעמים, אך אני מרגיש בבירור שאלו עליות דרגה ברמה של השם. לעתים פשוט צריך לנסות איזה שם ו"לחיות" איתו כמה דקות על מנת למצוא שם מוצלח יותר.


צמצום אלמנטים שאינם משרתים את מטרות 1-3. 
למי שנתקל ברעיונות אג'יליים - אני מניח שעקרון זה הוא מובן מאליו: Eliminate Waste. עדכון המטרה בעיקרון זה היא להימנע ממרכיבים בקוד שלא משרתים את הפונקציונליות, לא מונעים קוד-כפול ולא מסבירים את התנהגות המערכת, כל מיני "הכנות למזגן"[ג].

מי שעובד ב (Test Driven Development (TDD נהנה באופן מובנה מעקרון 1 ("כל הבדיקות עוברות") ועקרון 4 ("צמצום אלמנטים לא-חיוניים"). זו הדרך המהירה ליצירת קוד פשוט, שגם יישאר פשוט לאורך זמן.

מכאן נותרו רק 2 פעולות לשים לב אליהן:
צמצום כפילויות קוד [ב] ו כתיבת קוד המתאר כוונה / קוד ברור. המשיכו לעשות את אלו בצורה תמידית - והמבנה של הקוד שלכם, או ה "design" של הקוד שלכם - יהיה פשוט. זו הדרך היעילה ביותר שאני מכיר.

זה אולי נשמע קצת פשוט מדי: אולי ציפיתם לשימוש במחשבון של Cyclomatic complexity וטכניקות של ספירת Weighted Micro Function Points (ממש כמו ספירת קלוריות). 
צר לי לאכזב אתכם: כמה אנשים טובים השקיעו שנים ביצירת מודלים מתמטיים לתיאור סיבוכיות של תוכנה - אך בפועל כמה עקרונות פשוטים הם אלו שיגרמו לקוד שלכם להיות פשוט יותר, וקל יותר לתחזוקה.


שיהיה בהצלחה!



----

[א] יש המשתמשים במילה Design על מנת לתאר מצב של תוכנה חיה, ולא רק את התוכניות. לדוגמה: "Refactoring: Improving the Design of Existing Code". אם הרעיון הזה ברור לכם - הרגישו חופשיים להשתמש במילה design ולא ב structure.

[ב] אזהרה!: יש המבלבלים בין צמצום כפילות קוד בתוך המערכת, לבין שימוש-חוזר בקוד (code re-usability) או "צמצום כפילות קוד בעולם האנושי". בעוד ביטול כפילות-קוד בתוך הקוד שאתם כתבתם הוא כמעט-תמיד דבר טוב, שימוש חוזר בקוד ("חיצוני") הוא נושא מורכב עם הרבה ייתרונות וחסרונות. אני מתכנן לעסוק בנושא זה לעומק בפוסט נפרד.

[ג] המטאפורה הזו מטעה! מזגן הוא דבר מוכר שאנו יודעים לצפות לו ולבנות לו הכנה טובה. רוב ה"הכנות למזגן" בתוכנה הם ניחושים בעלטה אודות משהו לא-ידוע. בהתאמה: מנסיוני, רובן מתגלות כלא-יעילות או חסרות שימוש.


4 תגובות:

  1. דווקא לאחרונה מרטין פאולר ניסח בצורה היפה ביותר לטעמי את סוגית ה"מהו קוד טוב?".

    https://raw.github.com/gist/3753571/2f3a8702a0fd0ae08f9778956b8efe4d998b4d65/gistfile1.txt

    השבמחק
    תשובות
    1. תודה מוטי.

      תיקון קטן: נראה לי שהמקור של הטקסט הוא רוברט סי מרטין (Uncle Bob) ולא פאולר.
      מקור: http://goo.gl/3A4vE

      מחק
  2. היי. אהבתי את המדריך במיוחד את השיטה הפשוטה לבחירת שם . תוכל להסביר יותר על עקרון 4 ? בכללי זה נשמע הגיוני אבל גם כמו משהו שיכול למנוע מודולריות .

    השבמחק
    תשובות
    1. היי שני,

      אני שמח לשמוע שאהבת את הפסקה על בחירת השמות :)

      הכוונה בעיקרון 4 הוא *לא* להפחית את מספר המחלקות או הפונקציות במערכת (בהחלט שאיפה בעייתית: תמיד ניתן לכתוב את כל המערכת בפונקציה אחת) כי אם לחתור לצמצום מספר המרכיבים הלא חיוניים במערכת, כל אותם דברים שאנו מוסיפים "למקרה ש..." - מוסיפים לקוד לפני שהזדקקנו להם. דוגמה קלאסית היא לייצר מבנה של מתאם (Adapter) - כאשר יש לנו רק מימוש קונקרטי אחד או לייצר Abstract Class (או בכלל הורשה) "עבור הרחבה עתידית". לא צריך את זה - YagNi.

      כמובן שלעתים הוספה של מרכיב לא-נחוץ למערכת יכול ליצור קוד ברור יותר - למשל Abstract Class שכל תפקידו להדגיש את ייעודה של המחלקה שיורשת ממנו. זו אפשרות סבירה המתאימה למתן העדיפויות לעיקרון 3 על פני עיקרון 4.

      לסיכום: אם יש אלמנט / מרכיב בקוד, שאינו נועד לגרום למערכת לעבוד, אינו מונע קוד-כפול ואינו מסביר את התנהגות המערכת (לרוב זה יהיה "הכנה ל...משהו תיאורטי", או שאריות של קוד ישן שלא בשימוש) - יש לבטלו על מנת לשמור על המערכת פשוטה.

      אני חושב ש "צמצום מספר האלמנטים בקוד למינימום האפשרי" הוא דוגמה לשם נכון, שאינו מדויק (או בעל-משמעות). נתת לי הזדמנות לחזור לפוסט ולנסות לשפר אותו. תודה.

      ליאור

      מחק